EMS (reservations.seattleu.edu) – Room and event space booking

Incident Report for SeattleU IT Services

Resolved

This incident has been resolved.
Posted Apr 20, 2025 - 13:14 PDT

Investigating

We are continuing to investigate the issues causing our EMS to be unavailable
Posted Apr 19, 2025 - 22:12 PDT
This incident affected: Other.