Campus Bookstore System Issues
Incident Report for SeattleU IT Services
Resolved
Follett has resolved the technical issues affecting their payment and online ordering systems. All payment options are now operational in the Seattle University Campus Store. Follett staff are currently processing online orders and expect to have delayed orders completed by Monday, January 8. Digital book orders are still on a slight delay, but students should expect to receive their links via email by Friday evening.

The Campus Store will be open today until 6:00 PM and tomorrow from 10:00 AM to 2:00 PM to provide in-person assistance. Next week the store will return to regular business hours of 10:00 AM to 4:00 PM, Monday through Friday.

If you have any questions or concerns, please contact Michelle Conklin, Campus Store manager, at 1463mgr@follett.com. Thank you for your patience.
Posted Jan 05, 2024 - 13:41 PST
Investigating
Follett, the company managing the Seattle University Campus Bookstore, is experiencing a system-wide issue that may affect students relying on textbook and other orders. They have posted the following notification:

"We are currently experiencing a technical issue causing a delay of order processing and shipping. Digital processing is also temporarily delayed. Orders will be promptly processed once the issue is resolved. We apologize for the inconvenience."

We are monitoring this issue closely and will post updates as we have them. Thank you!
Posted Jan 04, 2024 - 10:49 PST
This incident affected: Other.