ITS Service Desk Phone Line is Down
Incident Report for SeattleU IT Services
Resolved
The phone line is back up and receiving phone calls.
Posted Aug 04, 2022 - 11:15 PDT
Investigating
The ITS Service Desk is currently unable to receive phone calls. If you need to open a ticket, please email servicedesk@seattleu.edu or open a ticket via our ticketing portal: https://seattleuniversity.atlassian.net/servicedesk/customer/portals.
Posted Aug 04, 2022 - 10:50 PDT
This incident affected: Other.