Canvas Service Degraded
Incident Report for SeattleU IT Services
Resolved
This incident has been resolved.
Posted Mar 03, 2021 - 14:44 PST
Investigating
Canvas is currently being very slow or unresponsive. The Center for Digital Learning and Innovation (CDLI) is in contact with Canvas to investigate the issue.
Posted Mar 03, 2021 - 14:09 PST
This incident affected: Canvas.