Microsoft Teams Degraded Service
Incident Report for SeattleU IT Services
Resolved
Microsoft reports that the issue affecting Teams has been resolved.
Posted Feb 18, 2021 - 08:19 PST
Investigating
Microsoft is reporting that Teams users may experience delays in receiving chat messages when using Microsoft Teams or can't join live events. Microsoft is investigating this issue.
Posted Feb 17, 2021 - 08:47 PST
This incident affected: Microsoft 365.