Intermittent Email Issues
Incident Report for SeattleU IT Services
Resolved
The issue affecting emails that were sent to quarantine has been resolved. All impacted emails have been delivered.
Posted Mar 03, 2021 - 18:02 PST
Update
Technicians continue work releasing emails from quarantine. This work is now projected to be completed by the end of business, today. We apologize for any inconvenience.
Posted Mar 03, 2021 - 12:57 PST
Update
Precautionary mail flow rules were set this morning at 7:40am to better protect against phishing attacks, but have caused some university emails to be sent to quarantine. IT Services technicians updated these rules at 9:30am and new emails are being sent as usual. Technicians are currently releasing emails that were quarantined. There is no need to resend these emails. They will begin arriving in mailboxes over the next hour and all affected emails should be released from quarantine by 1pm.
Posted Mar 03, 2021 - 10:04 PST
Update
Precautionary mail flow rules set as a response to last week's phishing attack have caused some university emails to be sent to quarantine. IT Services technicians are currently updating these rules and releasing emails. There is no need to resend these emails. They will begin arriving in mailboxes over the next hour as they are released from quarantine.
Posted Mar 03, 2021 - 09:43 PST
Monitoring
The malicious use of our relay to send phishing emails has been remediated. User email is working as expected. IT Services will work with application owners who need SMTP relay access to ensure they are working properly.
Posted Feb 26, 2021 - 10:11 PST
Identified
Seattle University became the target of a sophisticated email attack that has resulted in spam and malicious files appearing to be sent from the Seattle University email system. We have been notified by Microsoft that we are not the only victims of this type of attack today, and IT Services is supporting Microsoft's efforts to remedy the situation. Emails sent within Seattle university are not affected, but emails sent outside of SU may experience delays or intermittent issues.

We are working closely with Microsoft, and will update the community when a solution has been put in place.
Posted Feb 25, 2021 - 14:56 PST
This incident affected: CyberSecurity and Microsoft 365.