Canvas Unavailable
Incident Report for SeattleU IT Services
Resolved
This issue is now resolved. Canvas is now fully operational.
Posted Dec 08, 2021 - 06:14 PST
Monitoring
The underlying issue that caused Canvas to be impaired has been mitigated. AWS is seeing improvement in availability across most of the services that were impacted. All services are now independently working through service-by-service recovery. We continue to work toward full recovery for Canvas.
Posted Dec 07, 2021 - 15:30 PST
Update
Canvas is still unavailable due to the widespread AWS issue. At this time, there is no ETA for full recovery. Status updates can be seen on the Instructure status page: https://status.instructure.com.
Posted Dec 07, 2021 - 14:10 PST
Identified
Seattle University’s Canvas instance has been out of service since 8:00 AM this morning due to an Amazon Web Services outage that is also impacting many other web sites and applications. Instructure has identified the issue and is currently working on a fix. We will keep you posted as this situation develops.

In the meantime, if faculty need assistance rescheduling their finals, they should reach out to CDLI at cdli@seattleu.edu or contact Canvas Support at 833-250-2081.
Posted Dec 07, 2021 - 09:48 PST
Investigating
Canvas is unavailable due to an issue with AWS. We will update when more information is available.
Posted Dec 07, 2021 - 09:44 PST
This incident affected: Canvas.