Microsoft 365 Service Outage
Incident Report for SeattleU IT Services
Resolved
Microsoft has reported that the outage affecting multiple services has been resolved.
Posted Mar 15, 2021 - 16:06 PDT
Identified
Microsoft has identified the underlying cause of the problem and are taking steps to mitigate impact. At this time services leveraging Azure Active Directory may be affected including Microsoft Teams, Forms, SharePoint, Exchange Online, InTune, and Yammer.
Posted Mar 15, 2021 - 14:24 PDT
Investigating
Microsoft is reporting that users may be unable to access multiple Microsoft 365 services. Initial reports indicate that primary impact is to Microsoft Teams; however, other services including Exchange Online, InTune, Forms, and Yammer are also impacted.
Posted Mar 15, 2021 - 13:17 PDT
This incident affected: Microsoft 365.