ProcureSU Outage
Incident Report for SeattleU IT Services
Resolved
ProcureSU has returned to normal operation.
Posted Jul 27, 2021 - 08:14 PDT
Update
ProcureSU is currently having performance issues which is causing pages to load slower than normal and sometimes causing pages to timeout. The vendor is aware of the issue and is working on a solution.
Posted Jul 26, 2021 - 13:03 PDT
Monitoring
A fix has been implemented and the service has been restored, however some users may experience longer loading times than usual.
Posted Jul 26, 2021 - 09:50 PDT
Investigating
ProcureSU is currently unavailable. We’re working to resolve the issue and restore normal functionality as soon as possible.
Posted Jul 26, 2021 - 09:45 PDT
This incident affected: ProcureSU.