ProcureSU Performance Issues
Incident Report for SeattleU IT Services
Resolved
Jaggaer implemented multiple fixes to address the performance issues of their platform midday on Tuesday. Since then, their performance metrics have improved. At this point we consider the performance issues resolved.
Posted Aug 04, 2021 - 10:29 PDT
Update
Jaggaer continues remediation work to address performance issues which are affecting ProcureSU. They have implemented a software fix and increased their computing resources, both of which have helped to alleviate the problem. However, the platform continues to experience slower than average performance. We will continue to monitor their progress and update the status of ProcureSU as updates come in.
Posted Jul 29, 2021 - 09:57 PDT
Investigating
ProcureSU is currently having performance issues which is causing pages to load slower than normal and sometimes causing pages to timeout. Jaggaer is aware of the issue and is working on a solution.
Posted Jul 27, 2021 - 14:24 PDT
This incident affected: ProcureSU.