Microsoft 365 Degraded Service
Incident Report for SeattleU IT Services
Resolved
Microsoft reports that this incident has been resolved.
Posted Apr 02, 2021 - 05:27 PDT
Monitoring
Microsoft has mitigated this incident and services are functioning as expected.
Posted Apr 01, 2021 - 17:47 PDT
Identified
Microsoft has reported that a DNS issue is affecting multiple Microsoft 365 and Azure services. Impact is primarily to Microsoft Teams, though other Microsoft 365 and Azure services may be affected.

Additional affected services include but are not limited to: Dynamics 365, Microsoft Intune, Skype, SharePoint Online, OneDrive, Yammer, Power BI and Power Apps.
Posted Apr 01, 2021 - 15:42 PDT
This incident affected: Microsoft 365.